Getting an error trying to connect to my regions

* Technical questions about the grid, servers and viewers
* Technische Fragen über das Grid, Server und die Viewer

Getting an error trying to connect to my regions

Beitragvon fstltna » So 14. Mai 2017, 17:03

Translate to English translate to German Translate to French Translate to Italian Translate to Spanish Translate to Portuguese Translate to Czech Перевести на русский язык 翻译成中国

I upgraded my servers to ubuntu 16.04 and now i can't connect to my previously working regions. Is there something going on at metro? I get this error when trying to connect: 
Dateianhänge
Screen Shot 2017-05-14 at 7.54.40 AM.png
The error I am seeing
--- https://OpensimHosting.org --- Hosting for Opensim on Metropolis grid
--- https://OpensimCity.org ---
Benutzeravatar
fstltna
 
Beiträge: 15
Registriert: Sa 29. Jun 2013, 02:04
Wohnort: South San Francisco, CA

Re: Getting an error trying to connect to my regions

Beitragvon Sheera Khan » So 14. Mai 2017, 18:27

Translate to English translate to German Translate to French Translate to Italian Translate to Spanish Translate to Portuguese Translate to Czech Перевести на русский язык 翻译成中国

Hi fstltna,

nothing special is going on that I'd be aware of ...

Does the simulator start as usual?
Do you have a firewall active?
Did the configuration change on upgrade?
The error message indicates a problem where the grid services have stored a set of connection parameters (IP and port) that differs from the parameters used by the simulator. So maybe deleting the region via RegioManager Tool (https://metropolis.hypergrid.org/regioman.php) and restarting the simulator might help...

Ciaoo

Sheera
Benutzeravatar
Sheera Khan
 
Beiträge: 969
Registriert: Fr 22. Mär 2013, 14:18

Re: Getting an error trying to connect to my regions

Beitragvon fstltna » So 14. Mai 2017, 18:38

Translate to English translate to German Translate to French Translate to Italian Translate to Spanish Translate to Portuguese Translate to Czech Перевести на русский язык 翻译成中国

Sheera Khan hat geschrieben:Hi fstltna,

nothing special is going on that I'd be aware of ...

Does the simulator start as usual?
Do you have a firewall active?
Did the configuration change on upgrade?
The error message indicates a problem where the grid services have stored a set of connection parameters (IP and port) that differs from the parameters used by the simulator. So maybe deleting the region via RegioManager Tool (https://metropolis.hypergrid.org/regioman.php) and restarting the simulator might help...

Ciaoo

Sheera

Simulators start as usual and do not report any errors
No firewall as far as I know
No other changes were made related to opensim
I tried deleting the entry for one server, and it made no difference
Any other ideas?
--- https://OpensimHosting.org --- Hosting for Opensim on Metropolis grid
--- https://OpensimCity.org ---
Benutzeravatar
fstltna
 
Beiträge: 15
Registriert: Sa 29. Jun 2013, 02:04
Wohnort: South San Francisco, CA

Re: Getting an error trying to connect to my regions

Beitragvon fstltna » So 14. Mai 2017, 19:03

Translate to English translate to German Translate to French Translate to Italian Translate to Spanish Translate to Portuguese Translate to Czech Перевести на русский язык 翻译成中国

Ok, tracked it down part way. You can connect to port 9000 on the IPv4 address, but not the ipv6 address. Where do I enable the ports for ipv6 in the opensim config?
--- https://OpensimHosting.org --- Hosting for Opensim on Metropolis grid
--- https://OpensimCity.org ---
Benutzeravatar
fstltna
 
Beiträge: 15
Registriert: Sa 29. Jun 2013, 02:04
Wohnort: South San Francisco, CA

Re: Getting an error trying to connect to my regions

Beitragvon Sheera Khan » So 14. Mai 2017, 19:16

Translate to English translate to German Translate to French Translate to Italian Translate to Spanish Translate to Portuguese Translate to Czech Перевести на русский язык 翻译成中国

Glad you found the issue, but IPv6 isn't supported by OpenSim. Your region shouldn't report the IPv6 address to the grid servers so no viewer should try to use this address. Do you use the Metropolis-Edition of the OpenSim-Software?
In case of a real server with static IP-Address you could put in your correct IPv4-address in the Regions.ini-file:
ExternalHostName = 47.11.8.15
or
ExternalHostName = myserver.mydomain.tld (if the DNS resolves to your IPv4 only)

Ciaoo

Sheera
Benutzeravatar
Sheera Khan
 
Beiträge: 969
Registriert: Fr 22. Mär 2013, 14:18

Re: Getting an error trying to connect to my regions

Beitragvon fstltna » So 14. Mai 2017, 20:28

Translate to English translate to German Translate to French Translate to Italian Translate to Spanish Translate to Portuguese Translate to Czech Перевести на русский язык 翻译成中国

Yes I use the metro version of opensim, but oddly most of my servers in the manager area have the IPv6 address. I will try changing this and see if it sticks...

Marisa
--- https://OpensimHosting.org --- Hosting for Opensim on Metropolis grid
--- https://OpensimCity.org ---
Benutzeravatar
fstltna
 
Beiträge: 15
Registriert: Sa 29. Jun 2013, 02:04
Wohnort: South San Francisco, CA

Re: Getting an error trying to connect to my regions

Beitragvon Sheera Khan » So 14. Mai 2017, 21:47

Translate to English translate to German Translate to French Translate to Italian Translate to Spanish Translate to Portuguese Translate to Czech Перевести на русский язык 翻译成中国

If all else fails you could resort to disabling the IPv6 address of your interfaces - I'd have to lookup though how it's done on Ubuntu ...

To test it temporarily you could issue the command:
Code: Alles auswählen
 echo 1 > /proc/sys/net/ipv6/conf/all/disable_ipv6


to make the setting permanent you have to create a file /etc/sysctl.d/01-disable-ipv6.conf :
Code: Alles auswählen
 net.ipv6.conf.all.disable_ipv6 = 1


I hope that helps a bit :-)

Ciaoo

Sheera

PS.: Source for those tipps: https://www.thomas-krenn.com/de/wiki/IPv6_deaktivieren
Benutzeravatar
Sheera Khan
 
Beiträge: 969
Registriert: Fr 22. Mär 2013, 14:18

Re: Getting an error trying to connect to my regions

Beitragvon fstltna » Mo 15. Mai 2017, 00:03

Translate to English translate to German Translate to French Translate to Italian Translate to Spanish Translate to Portuguese Translate to Czech Перевести на русский язык 翻译成中国

Awesome - that fixed it. Either ubuntu 16 or latest mono must be returning the ipv6 address instead of the ipv4 address they used to. When I disable the ipv6 interface everything works fine...
--- https://OpensimHosting.org --- Hosting for Opensim on Metropolis grid
--- https://OpensimCity.org ---
Benutzeravatar
fstltna
 
Beiträge: 15
Registriert: Sa 29. Jun 2013, 02:04
Wohnort: South San Francisco, CA


Zurück zu Technical Support / Technische Unterstützung

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot] und 0 Gäste



Powered by phpBB

Deutsche Übersetzung durch phpBB.de
.

Style designed by Artodia.