Probleme mit Asset-Service (fcache)

* Technical questions about the grid, servers and viewers
* Technische Fragen über das Grid, Server und die Viewer

Probleme mit Asset-Service (fcache)

Beitragvon Data Rossini » Mo 17. Apr 2017, 08:58

Translate to English translate to German Translate to French Translate to Italian Translate to Spanish Translate to Portuguese Translate to Czech Перевести на русский язык 翻译成中国

Hallo Liebe MetroGrid-Admins,

seit gestern sind mir nach dem Neustart des OpenSim-Servers Probleme mit dem Assetservice aufgefallen (vorher nie).
An der Konfiguration (OpenSim.ini, GridCommon.ini, FlotsamCache.ini ) wurde nichts geändert.
In diesem Zusammenhang werden auch einige Scripte nicht mehr gestartet und müssen anschließend von Hand gestartet werden (Script reset im Viewer).
Hatte ursprünglich einen Homeserver und bin später auf einen Root-Server gewechselt. Der Homeserver mit einer anderen Sim wurde vorerst stillgelegt.
Nachdem Probleme aufgetaucht sind, habe ich auch nochmals versuchsweise OpenSim auf dem Homeserver gestartet und hier treten nun auch Probleme mit dem Asset-Service auf.
Also 2 unterschiedliche OpenSim-Server.
Nach dem Leeren des fcache auf der Console mit "fcache clear" gibt es vermehrt -zig Fehler-Einträge im Protokol (siehe nachfolgend).

Vielleicht habt Ihr eine Idee und könnt mir bitte mitteilen an was es liegen könnte.
Aber es Eilt nicht. Wir betreiben das alles nur als Hobby.

LG Data

Folgende Einträge gibt es z. B. im OpenSim.log (nur einer, die anderen sehen bis auf die ID genauso aus):

2017-04-16 21:55:25,314 ERROR - OpenSim.Framework.SynchronousRestObjectRequester [SynchronousRestObjectRequester]: WebException for GET http://assets.hypergrid.org:8006/assets ... 2ad4fb1bbd OpenSim.Framework.AssetBase
System.Net.WebException: Error: ConnectFailure (Connection refused) ---> System.Net.Sockets.SocketException: Connection refused
at System.Net.Sockets.Socket.Connect (System.Net.EndPoint remoteEP) [0x000f1] in /home/abuild/rpmbuild/BUILD/mono-3.0.6/mcs/class/System/System.Net.Sockets/Socket_2_1.cs:1236
at System.Net.WebConnection.Connect (System.Net.HttpWebRequest request) [0x0019b] in /home/abuild/rpmbuild/BUILD/mono-3.0.6/mcs/class/System/System.Net/WebConnection.cs:209
--- End of inner exception stack trace ---
at System.Net.HttpWebRequest.EndGetResponse (IAsyncResult asyncResult) [0x00065] in /home/abuild/rpmbuild/BUILD/mono-3.0.6/mcs/class/System/System.Net/HttpWebRequest.cs:926
at System.Net.HttpWebRequest.GetResponse () [0x0000e] in /home/abuild/rpmbuild/BUILD/mono-3.0.6/mcs/class/System/System.Net/HttpWebRequest.cs:932
at OpenSim.Framework.SynchronousRestObjectRequester.MakeRequest[Int32,AssetBase] (System.String verb, System.String requestUrl, Int32 obj, Int32 pTimeout, Int32 maxConnections, IServiceAuth auth) [0x00000] in <filename unknown>:0
2017-04-16 21:55:25,317 ERROR - OpenSim.Region.Framework.Scenes.SceneObjectPartInventory [PRIM INVENTORY]: Couldn't start script collide_sensor, 6d18709e-5aa3-4930-9a73-b64dbc315e47 at <488.1515, 432.031, 716.2667> in Desertcity since asset ID 113235ed-3933-4aea-8ac1-c32ad4fb1bbd could not be found
Benutzeravatar
Data Rossini
 
Beiträge: 19
Registriert: Sa 28. Jun 2014, 08:52

Re: Probleme mit Asset-Service (fcache)

Beitragvon Zak Spot » Mo 17. Apr 2017, 09:59

Translate to English translate to German Translate to French Translate to Italian Translate to Spanish Translate to Portuguese Translate to Czech Перевести на русский язык 翻译成中国

Hi Data,

vielen Dank für den ausführlichen Report. Wir haben an diesem Wochenende ein paar Änderungen durchgeführt z.B. Datenbank Server Upgrade, neues Server Montoring Tool etc. Um genau zu sein hatte Asset Service Nummer 5 einen Fehlstart beim Reboot (meine Schuld ;)). Durch das neue Monitoring Tool ,das Uncle CM aufgesetzt hat, werden wir sowas zukünftig schneller erkennen können. Ich habe das jetzt nochmal manuell behoben.

Frohe Rest-Ostern
Zak
Zak Spot
 
Beiträge: 965
Registriert: Di 19. Okt 2010, 11:23

Re: Probleme mit Asset-Service (fcache)

Beitragvon Data Rossini » Mo 17. Apr 2017, 10:36

Translate to English translate to German Translate to French Translate to Italian Translate to Spanish Translate to Portuguese Translate to Czech Перевести на русский язык 翻译成中国

Hallo Zak,

vielen Dank für die schnelle und kompetente Hilfe.
Verstehe nun den Zusammenhang.

Dank Dir und den anderen Teammitgliedern fühlt man sich hier in diesem Grid gut aufgehoben.
Wünsche Dir einen schönen Ostermontag.

LG Data
Benutzeravatar
Data Rossini
 
Beiträge: 19
Registriert: Sa 28. Jun 2014, 08:52


Zurück zu Technical Support / Technische Unterstützung

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste



Powered by phpBB

Deutsche Übersetzung durch phpBB.de
.

Style designed by Artodia.