NAT Loopback for Winows 10

* Technical issues about Viewers
* Technische Fragen über Viewer

NAT Loopback for Winows 10

Beitragvon Impresario » Di 19. Jan 2016, 00:22

Translate to English translate to German Translate to French Translate to Italian Translate to Spanish Translate to Portuguese Translate to Czech Перевести на русский язык 翻译成中国

After switching to Windows 10 (a decision i've regretted for a number of reasons), I can no longer log into my regions. I remember having this issue in Win 7 and installing a NAT Loopback adapter, but when I attempt to run that batch file now I get an error (something about a bad directory and not being Windows NT).

I also attempted to activate the Win 10 loopback adapter, but this had no effect.

I'd be grateful for any advice.
Benutzeravatar
Impresario
 
Beiträge: 32
Registriert: Di 6. Jan 2015, 17:20

Re: NAT Loopback for Winows 10

Beitragvon Lurch Swindlehurst » Di 19. Jan 2016, 08:15

Translate to English translate to German Translate to French Translate to Italian Translate to Spanish Translate to Portuguese Translate to Czech Перевести на русский язык 翻译成中国

I have the same problem some day ago.
But the resolution was very nice: it was not a problem of win 10. In the last days my provider change to IP6, so i dont get a IP4 adress any more. After a support call they change back.

Lurch
Benutzeravatar
Lurch Swindlehurst
 
Beiträge: 53
Registriert: Do 2. Aug 2012, 19:39
Wohnort: Berlin

Re: NAT Loopback for Winows 10

Beitragvon Mareta Dagostino » Di 19. Jan 2016, 10:34

Translate to English translate to German Translate to French Translate to Italian Translate to Spanish Translate to Portuguese Translate to Czech Перевести на русский язык 翻译成中国

It seems, that the IPv6 problem becomes more and more important. Maybe, USA has so much IPv4 addresses that there is no interest in modern internet, but in asia, developing countries and actually also in Europe it becomes difficult for end users to get IPv4 addresses. My provider in Germany has switched to IPv6 more than a year ago...
(My regions are on a rented server in a computing centre, with exactly one IPv4. For each additional IPv4 I would need to declare the technical reason according to the so called RIPE guidelines. On that server I have a complete IPv6 subnet as default.)
https://hyperweb.eu => Server-Tutorial für Linux mit OpenSim, konfigurierter OpenSim Arriba Binärdownload!
Benutzeravatar
Mareta Dagostino
 
Beiträge: 757
Registriert: Sa 29. Jan 2011, 20:26

Re: NAT Loopback for Winows 10

Beitragvon Impresario » Di 19. Jan 2016, 15:27

Translate to English translate to German Translate to French Translate to Italian Translate to Spanish Translate to Portuguese Translate to Czech Перевести на русский язык 翻译成中国

I have a IPv4 address, so I don't think that's the issue.

Also, I can readily log on to other Metropolis sights, just not the regions I host on my server. I can only log on or TP to my server from a different network than my own.
Benutzeravatar
Impresario
 
Beiträge: 32
Registriert: Di 6. Jan 2015, 17:20

Re: NAT Loopback for Winows 10

Beitragvon Eryn Galen » Mi 20. Jan 2016, 12:41

Translate to English translate to German Translate to French Translate to Italian Translate to Spanish Translate to Portuguese Translate to Czech Перевести на русский язык 翻译成中国

Maybe for a bit of clarification:
Impresario and myself tested extensively one evening and it looks like NAT is to blame. His router cannot do the loopback and the tools that are available ot aredescribed do not have the desired effect.
Like he said: the tool creates an error and the Microsoft internal one seems to have no effect even though we enabled it.
Does maybe someone know of a workaround?
It might be important to say that Impresario has a static IP through a dynDNS service.
Benutzeravatar
Eryn Galen
 
Beiträge: 972
Registriert: So 13. Jan 2013, 22:48

Re: NAT Loopback for Winows 10

Beitragvon loguk » Di 9. Feb 2016, 15:46

Translate to English translate to German Translate to French Translate to Italian Translate to Spanish Translate to Portuguese Translate to Czech Перевести на русский язык 翻译成中国

I have just been through a similar situation, having converted from Windows 7 to Windows 10 for my server machine. I also have to use a software NAT loopback because my router does not provide NAT loopback.

I have it working - I found that using DHCP to allocate an IP address for the network adapter resolved my problem - as soon as I switched to trying to use a fixed IP address (which I want) the server failed to communicate but gave no errors.

Zak's NAT loopback setter works fine on Windows 10.

I will continue investigating how to get it working with a fixed (internal) IP address, but for the moment I am just glad to know that something works ;-
Aaron Aldwych (Crystal Palace region)
Benutzeravatar
loguk
 
Beiträge: 28
Registriert: Fr 3. Apr 2015, 22:08

Re: NAT Loopback for Winows 10

Beitragvon Impresario » Fr 19. Feb 2016, 03:55

Translate to English translate to German Translate to French Translate to Italian Translate to Spanish Translate to Portuguese Translate to Czech Перевести на русский язык 翻译成中国

What did you change to cause DHCP to be used for the network adapter?
Benutzeravatar
Impresario
 
Beiträge: 32
Registriert: Di 6. Jan 2015, 17:20

Re: NAT Loopback for Winows 10

Beitragvon loguk » Mo 22. Feb 2016, 22:08

Translate to English translate to German Translate to French Translate to Italian Translate to Spanish Translate to Portuguese Translate to Czech Перевести на русский язык 翻译成中国

I had to allow DHCP to allocate 'dynamic' IP address - I set the use DHCP option in the adapter settings - as it happens my system is pretty much stable, and so even using DHCP my server machine IP address has not changed, if it does I have to reset the port-forwards in my router.

Steve
Aaron Aldwych (Crystal Palace region)
Benutzeravatar
loguk
 
Beiträge: 28
Registriert: Fr 3. Apr 2015, 22:08


Zurück zu OpenSim Viewer

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste



Powered by phpBB

Deutsche Übersetzung durch phpBB.de
.

Style designed by Artodia.