Error message when trying to connect

* Technical questions about the grid, servers and viewers
* Technische Fragen über das Grid, Server und die Viewer

Error message when trying to connect

Beitragvon Ferd Frederix » So 19. Mai 2013, 08:19

Translate to English translate to German Translate to French Translate to Italian Translate to Spanish Translate to Portuguese Translate to Czech Перевести на русский язык 翻译成中国

Congratulations on getting the system back!

I changed the two lines in gridcommon.ini:

AssetServerURI = "http://virtual.hypergrid.org:8006"
InventoryServerURI = "http://virtual.hypergrid.org:8005"

Version is 0.7.5, on Windows 7 with MySQL, all was running well before the shutdown.

When I boot, the log files show two errors: The first, a terrain error in the DB, and the second is "Object reference not set to an instance of an object."

Code: Alles auswählen
2013-05-09 18:58:13,778 DEBUG - OpenSim.Region.Framework.Scenes.Scene [SCENE]: Using the BestAvatarResponsiveness prioritization scheme
2013-05-09 18:58:13,803 ERROR - OpenSim.Data.MySQL.MySQLSimulationData [REGION DB]: MySQL error in ExecuteReader: Table '.\karisimbi\terrain' is marked as crashed and should be repaired
2013-05-09 18:58:13,805 WARN  - OpenSim.Region.Framework.Scenes.Scene [TERRAIN]: Scene.cs: LoadWorldMap() - Failed with exception Table '.\karisimbi\terrain' is marked as crashed and should be repaired   at MySql.Data.MySqlClient.MySqlStream.ReadPacket()
   at MySql.Data.MySqlClient.NativeDriver.GetResult(Int32& affectedRow, Int32& insertedId)
   at MySql.Data.MySqlClient.Driver.GetResult(Int32 statementId, Int32& affectedRows, Int32& insertedId)
   at MySql.Data.MySqlClient.Driver.NextResult(Int32 statementId)
   at MySql.Data.MySqlClient.MySqlDataReader.NextResult()
   at MySql.Data.MySqlClient.MySqlCommand.ExecuteReader(CommandBehavior behavior)
   at OpenSim.Data.MySQL.MySQLSimulationData.ExecuteReader(MySqlCommand c)
   at OpenSim.Data.MySQL.MySQLSimulationData.LoadTerrain(UUID regionID)
   at OpenSim.Services.Connectors.SimulationDataService.LoadTerrain(UUID regionID)
   at OpenSim.Region.Framework.Scenes.Scene.LoadWorldMap()
2013-05-09 18:58:13,808 INFO  - OpenSim.Region.Physics.Manager.PhysicsPluginManager [PHYSICS]: Added meshing engine: ZeroMesher
2013-05-09 18:58:13,814 INFO  - OpenSim.Region.Physics.Manager.PhysicsPluginManager [PHYSICS]: Added physics engine: basicphysics
2013-05-09 18:58:13,824 INFO  - OpenSim.Region.Physics.Manager.PhysicsPluginManager [PHYSICS]: Added physics engine: BulletSim
2013-05-09 18:58:13,826 INFO  - OpenSim.Region.Physics.Manager.PhysicsPluginManager [PHYSICS]: Added meshing engine: Meshmerizer
2013-05-09 18:58:13,831 INFO  - OpenSim.Region.Physics.Manager.PhysicsPluginManager [PHYSICS]: Added physics engine: OpenDynamicsEngine
2013-05-09 18:58:13,833 INFO  - OpenSim.Region.Physics.Manager.PhysicsPluginManager [PHYSICS]: Added physics engine: POS
2013-05-09 18:58:13,834 INFO  - OpenSim.Region.Physics.Manager.PhysicsPluginManager [PHYSICS]: creating meshing engine Meshmerizer
2013-05-09 18:58:13,836 INFO  - OpenSim.Region.Physics.Manager.PhysicsPluginManager [PHYSICS]: creating OpenDynamicsEngine
2013-05-09 18:58:13,838 DEBUG - OpenSim.Framework.Util [UTIL]: Loading native Windows library at lib64/ode.dll
2013-05-09 18:58:13,887 ERROR - OpenSim.Application [APPLICATION]:
APPLICATION EXCEPTION DETECTED: System.UnhandledExceptionEventArgs

Exception: System.NullReferenceException: Object reference not set to an instance of an object.
   at OpenSim.OpenSimBase.SetupScene(RegionInfo regionInfo, Int32 proxyOffset, IConfigSource configSource, IClientNetworkServer& clientServer)
   at OpenSim.OpenSimBase.CreateRegion(RegionInfo regionInfo, Boolean portadd_flag, Boolean do_post_init, IScene& mscene)
   at OpenSim.OpenSimBase.CreateRegion(RegionInfo regionInfo, Boolean portadd_flag, IScene& scene)
   at OpenSim.ApplicationPlugins.LoadRegions.LoadRegionsPlugin.PostInitialise()
   at OpenSim.OpenSimBase.StartupSpecific()
   at OpenSim.OpenSim.StartupSpecific()
   at OpenSim.Framework.Servers.BaseOpenSimServer.Startup()
   at OpenSim.Application.Main(String[] args)

Application is terminating: True


If I comment out ODE and swith to Basic physics, I get similar results:

Code: Alles auswählen
01:06:22 - [PHYSICS]: creating meshing engine Meshmerizer
01:06:22 - [PHYSICS]: creating basicphysics
OpenSim threw an exception:
System.NullReferenceException: Object reference not set to an instance of an obj
ect.
   at OpenSim.OpenSimBase.SetupScene(RegionInfo regionInfo, Int32 proxyOffset, I
ConfigSource configSource, IClientNetworkServer& clientServer)
   at OpenSim.OpenSimBase.CreateRegion(RegionInfo regionInfo, Boolean portadd_fl
ag, Boolean do_post_init, IScene& mscene)
   at OpenSim.OpenSimBase.CreateRegion(RegionInfo regionInfo, Boolean portadd_fl
ag, IScene& scene)
   at OpenSim.ApplicationPlugins.LoadRegions.LoadRegionsPlugin.PostInitialise()
   at OpenSim.OpenSimBase.StartupSpecific()
   at OpenSim.OpenSim.StartupSpecific()
   at OpenSim.Framework.Servers.BaseOpenSimServer.Startup()
   at OpenSim.Application.Main(String[] args)
   at OpenSim._32BitLaunch.Program.Main(String[] args) in C:\OpenSim\trunk6\Open
Sim\Tools\OpenSim.32BitLaunch\Program.cs:line 47

Application will now terminate!

Any idea what to do next?

I was thinking of pointing the system to a blank database, and restoring my OAR to it. Was not sure if that was a good idea, or not.

Regards:

Ferd Frederix
Benutzeravatar
Ferd Frederix
 
Beiträge: 2
Registriert: So 19. Mai 2013, 07:00

Re: Error message when trying to connect

Beitragvon Zak Spot » So 19. Mai 2013, 09:05

Translate to English translate to German Translate to French Translate to Italian Translate to Spanish Translate to Portuguese Translate to Czech Перевести на русский язык 翻译成中国

Hi Ferd,

for the first error you need to log into your mysql server and make a mysql "REPAIR TABLE terrain;" statement on the table terrain in your DB. Then its ok. More infos here dev.mysql.com/doc/refman/5.1/en/repair-table.html its better to shutdown OpenSim while doing that. Im not sure yet about the second error but it depends on the first i think.

And yes you can solve this with a blank database too. If you have backups do it.

Greetings
Zak
"Metropolis machts möglich." - sloganizer.net
Zak Spot
 
Beiträge: 965
Registriert: Di 19. Okt 2010, 11:23

Re: Error message when trying to connect

Beitragvon Ferd Frederix » So 19. Mai 2013, 17:06

Translate to English translate to German Translate to French Translate to Italian Translate to Spanish Translate to Portuguese Translate to Czech Перевести на русский язык 翻译成中国

"REPAIR TABLE terrain;" fixed it, thank you very much! :D

~Ferd
Benutzeravatar
Ferd Frederix
 
Beiträge: 2
Registriert: So 19. Mai 2013, 07:00

Re: Error message when trying to connect

Beitragvon RoberWillis » Mo 28. Jun 2021, 12:47

Translate to English translate to German Translate to French Translate to Italian Translate to Spanish Translate to Portuguese Translate to Czech Перевести на русский язык 翻译成中国

There is a problem with the connectivity of this device for the uses. The passages of the https://thoughtnova.com/5-ways-to-access-free-entertainment-during-the-covid-19-quarantine/a0a0a4l are found good for the citizens. The reform is shaped for the use of the connecting software for the individuals.
Benutzeravatar
RoberWillis
 
Beiträge: 1
Registriert: Mo 28. Jun 2021, 12:46


Zurück zu Technical Support / Technische Unterstützung

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast



Powered by phpBB

Deutsche Übersetzung durch phpBB.de
.

Style designed by Artodia.